Skip to main content

Stockfish version and engine limits

Why the newest Stockfish and certain engine options are not available?

Question

This article is for you if have any of the following quetions:

  • Why the newest Stockfish version, e.g. 14+, is not available?

  • Why I cannot increase memory or CPU for the engine?

  • Why I cannot enable NNUE?

Anwer

The reason for this is that the extension uses the embedded Lichess analysis board and it can be only embedded in such a limited way i.e. Stockfish 10+ WASM, no NNUE, limited engine options.

Whenever you need these options we recommend clicking the "Lichess" link just above the analysis board which opens the scanned diagram directly in Lichess analysis where all the options are available.

Plans

In the future we are planning to add our custom analysis board that won't have these limitations so everyone will be able to use more powerful analysis directly in our apps.